I/O HE10 Hardware or Firmware Problem?

512 in and 512 out

Moderators: TomHat, simonB, Benno

mschaeck
Posts: 2
Joined: Sun May 27, 2012 11:59 am

I/O HE10 Hardware or Firmware Problem?

Postby mschaeck » Sun May 27, 2012 12:01 pm

I use a DVC3 512 Interface to control DMX devices. The reason why I bought your device is the stand alone mode.

I want to connect 8 switches to the HE10 dry contact port socket. But the switches won't work.

Than I figured out that in the Dashlight Virtual Controler Software over the testwindow the actual portstates are shown. If I don't connect anything to the HE10 the Port P3 and P4 are set (and thats not right). All other are working fine, only this two bits are set all the time, also if nothing is connected.

I put an external weak pullup to the 3.3V. Then the Bits are cleared and working fine. For me it seams that there is no or a too high pullup resistor in you device.
Because I bought the device only a few days ago, for me the question is if that is a hardware problem, or if there is a firmware problem with the pullup and you can make a firmwareupdate with stronger pullups.

Please send me a message what you think it is, so i can send the device back to the shop.

simonB
Site Admin
Posts: 1262
Joined: Wed Dec 02, 2009 3:57 pm

Postby simonB » Mon May 28, 2012 12:24 pm

This is the problem:
http://www.nicolaudie.com/online_manual ... gY7Js2.htm

If you would rather not solder the resistors, let me know and I will arrange a return.

mschaeck
Posts: 2
Joined: Sun May 27, 2012 11:59 am

Postby mschaeck » Mon May 28, 2012 7:53 pm

Thanks for the Info... That was what I was thinking about. How can you arrange a return or should I send it back to the store where I bought it and tell them to get a device with a s/n above 355000.

do the s/n above 355000 have a different pcb/layout or are the modifications refinished like on the picture from the link you gave to me.


Return to “DVC3 512 / DVC2 512”

Who is online

Users browsing this forum: No registered users and 2 guests