Bug report: Failure storing and loading effekt generator settings

The new Daslight - for PC and Mac

Moderators: TomHat, simonB, Benno

soenkePKS
Posts: 6
Joined: Fri Aug 10, 2018 4:53 am
Operating System: Windows
Location: Germany - Hannover

Bug report: Failure storing and loading effekt generator settings

Postby soenkePKS » Fri Aug 10, 2018 9:20 am

Hey,

we are using Daslight 4 to control our Moving-Heads. They are controlled with 18 DMX channels.
We now have configured some effects with two or more functions. For example we use an curve effect for shutter and another curve effect for tilt. No other channel is controlled by the effect generator.

When storing and loading the settings again the channel selection of the curve effects is wrong. Both now select the correct channel (shutter / tilt) selected bevore but now also all channels above 15 (i.e. channel 16, 17 and 18) are selected.
Seems that storing/loading the channel selection for effect generator is not working properly.

We have tried the new version of august already - but experienced the same problem.

Operating system is Windows 10.

Benno
Posts: 529
Joined: Tue Mar 31, 2015 3:31 pm
Location: Brighton
Contact:

Re: Bug report: Failure storing and loading effekt generator settings

Postby Benno » Fri Aug 10, 2018 2:02 pm

Hi soenkePKS,

Do you mean saving the effect .xep file? Just tested and cannot reproduce in the latest official Aug version.

Please make sure you are using the latest Official version of Daslight 4 (02.08.18 - links below).
www.daslight.com/download.htm

Kind regards
Benno
--
Product Support

soenkePKS
Posts: 6
Joined: Fri Aug 10, 2018 4:53 am
Operating System: Windows
Location: Germany - Hannover

Re: Bug report: Failure storing and loading effekt generator settings

Postby soenkePKS » Sun Aug 12, 2018 7:02 pm

Hey,
i've just double checked and yes i'm using the latest version and yes saving xep is leading to this problem.

Ive reproduced with two different Device-Types and get different results, perhaps yours was just working.
How i've reproduced
1. Create new Project
2. Patch one "American DJ - visi beam 5rx" in Mode 2 (19 Channels)
3. Add Curve effect and only select x
before.PNG
before saving
before.PNG (80.63 KiB) Viewed 100 times

4. Save effect
5. Reset effect generator (i.e. clicking on x in the upper right corner)
6. Load effect from previously saved file
7. The channel selection is wrong
after.PNG
after restoring
after.PNG (75.8 KiB) Viewed 100 times

In case of the Visi beam now the channel "pan tilt macros" is selected. (As you can see in the combobox in the screenshot).

In my case (v-lite lv-q4 with mode 2) now the last 3 Channels are selected, but should not be.

I've attached the saved effects and my device configuration.

Let me know if you need something else!

Thanks for your support!
Attachments
bug.zip
(167.12 KiB) Downloaded 5 times

Benno
Posts: 529
Joined: Tue Mar 31, 2015 3:31 pm
Location: Brighton
Contact:

Re: Bug report: Failure storing and loading effekt generator settings

Postby Benno » Tue Aug 14, 2018 2:40 pm

Thanks for the very clear bug report. Managed to reproduce now and passed all the info on to the developers so they can work on fixing this for the next version. Kind regards
Benno

--

Product Support


Return to “Daslight 4”

Who is online

Users browsing this forum: No registered users and 5 guests